Introduction to ACES Video from user Andrey Lebrov (Tech Level: Low)

Tags: #<Tag:0x00007fe449e760f0> #<Tag:0x00007fe449e76000> #<Tag:0x00007fe449e75f10> #<Tag:0x00007fe449e75e20>

This is a very entertaining and easy to understand presentation of ACES created by ACES user (DP, CGI/VFX Artist) Andrey Lebrov. It includes a discussion of how he recommends to use ACES in Blackmagic Fusion, Davinci Resolve and After Effects.

Thanks to Andrey…another example of the ACES community helping each other learn and grow.

PS: Sorry forgot to mention, i also disabled the grade of course before exporting as EXR sequence, just with the ALEXA IDT ‘On’

Hi there, i have tried to replicate the workflow but couldn’t get it quite right. My scenario is a bit different, nonetheless should work. My setup is a Resolve 16 to AE 2019 roundtrip. Pre-grading of VFX plates and of dailies for editorial. The whole thing in ACES 1.03 with a mix of Monstro 8K and Alexa LF footage. Trying to wrap my head around the IPP2 from RED but this would be another topic for later. Did just a test with the Alexa footage and no matter what i try i cannot get the grade nailed.

In AE it looks a bit warmer than in Resolve. In Resolve i set the ACES 1.03, timeline to the default AP1, in the media tab applied the Alexa IDT, did a simple primary grade, disabled the Rec709 ODT and exported as half float EXR (PIZ compression), so far so good. In AE set the working space to ACEScg with the ‘linearize’ option ON. In the Media setting ‘preserve RGB’, looks dark (linear), applied the Color Space Converter to ACEScg (input) and the output to REC709 2.4 Gamma. Voila, got normal looking.

After that applied the OCIO thingy ‘Input ACES2065-1, Output to ACEScg’ which didn’t make almost any difference?? Made an adjustment layer above and applied my previously exported 3D LUT (exported of course with the ODT turned off) So while it looks quite similar, still the grade is different. Why??? So i tried the sRGB and it got closer but not the same. What i am doing wrong here. The look (LUT) also looks different.

Any ideas?? I guess the Rec709 Gamma 2.4 is not the same, as well as the LUT is applied in AE, i tried to change the order of LUT right after the footage but still not the same. I managed to get it right in Fusion and Nuke, just AE is a pain in the bud.

Really appreciate any input to solve that riddle.

Thanks,
Mark

1 Like

Welcome and thanks for your first post!

OK, here my update on the AE front (Puhh… what a struggle). Seems the new ICIO plugin for AE handles things quite differently. I tried the workflow from Andrey with a test scene from ARRI shot on the ALEXA LF 1920x1080, ProRes 4444, 800ASA, 24fps, 3200K and it didn’t work at all in AE 2019. What was interesting though that simply applying an OCIO with the correct input (in this case ARRI - V3LogC (EI800) -Wide Gammut) and the Ouput set to ACEScg gave me immediately a correct Rec709 image, nearly (not 100%) to the Rec709 image in Resolve 16. No Color Profile Converter applied. Now the new plugin has 2 options one for conversion and one just for display. What i also found out that the exported EXR’s from Davinci perfectly matched to Resolve. So at least the EXR exports were correct. The only caveat is the LUT. This time i didn’t use Curves, besides the Primaries, just a slight Gamma shift towards blue.

Exported as 3D LUT and applied on Adjustment layers. The simple ‘apply LUT’ did clamp highlights, so i used the Lumetri Basic LUT slot. It worked BUT still too warm. So i duplicated the same Adjustment layer and fiddled around until it almost matched. Still the highlights a bit too warm, but overall the mid-tones pretty close. To give an VFX artist an idea about the mood of the scene i would say good enough BUT why we cannot get it perfectly matched we probably have to ask Adobe. To test whether i am ACES space i applied a Lens Blur and it worked beautifully. So to conclude, possible? yes/maybe/hopefully. Easy? No, definitely not. All works but to get a grade perfectly transferred seems a bit of a black art.

Its hard to know exactly what your workflow is, but I imagine you are set up to apply the grade in Resolve in the working space of ACEScct or ACEScc. To match this in After Effects you need to apply the LUT in the same working space. Therefore I suggest you try having two OCIO adjustment layers at the top of your comp, either side of the LUT layer; layer 3 being a colour space conversion from ACEScg to ACEScc(t); layer 2 having the Lumetri effect with the LUT; and layer 1 being an OCIO display transform with the input set to ACEScc(t).

You could of course have the three effects on a single adjustment layer, but separating them like this makes it easier to toggle them on and off to check things.

1 Like

Hi Nick, thanks, works perfect and what you suggested totally makes sense since working space in Davinci is set to ACEScct, so applying a LUT in ACEScg in AE cannot work. I didn’t do this step before assuming that whatever i do in Davinci gets applied to AP0 and not the set working space like CC or CCT, which i always assumed as just viewing LUT’s.

Now i fully understand the ACES concept that it let’s you chose the working color space limiting you to the either linear or log style of working in the Rec2020+ (AP1) gamut but still parsing AP0 for information, right? Or is this a real conversion and data get truncated?

But thanks for the solution, actually is quite simple and logic once you grasp the concept, really like it and is spot on, also the EXR files render extremely fast even can get quite big.

Thanks for helping me out like in my last email asking for advise :wink: BIG SHOUT OUT TO NICK and ACES team, AWESOME work guys !!