DaVinci Resolve DCTL and OFX Plugins

Tags: #<Tag:0x00007f964891d350> #<Tag:0x00007f964891d210> #<Tag:0x00007f964891d0d0> #<Tag:0x00007f964891cf90> #<Tag:0x00007f964891ce50> #<Tag:0x00007f964891cd10> #<Tag:0x00007f964891cbd0>

(Charles Boileau) #33

I read the first post when you started the thread. I was unable to get to testing before Monday. That detail must of slipped my mind after started to test the plugin in 14. Sorry for not running thru the instructions properly. I’ve been working on a workflow for months (that was at a dead end) and I was very excited about your plugin.

Did test in Beta 15 and it works. This really opens up a new world for us… The DCTL took a few seconds to load… Is this expected as it is looking up the all the different files?

Thanks again for the great work. I’d be willing to contribute in any way to help you with development.


(Paul Dore) #34

The OFX Plugin has been updated to include more IDTs and ODTs. Hue degrees have been reverted back to the original values and order (green at 120, blue at 240, etc.), so once again compliant with the source CTL code.

(Charles Boileau) #35

Hi to all,

I’ve tested extensively the DCTLs scripts and they will quite useful in R15. Especially, considering that (for now) all of the edit created titles, transitions etc… go thru the ACES pipeline unmanaged.

I did not find any bugs or any performance problems associated with the use of the DCTLs. There is some caveats if the user is not well versed in understanding ACES as you could potentially grade outside or before ACES and induce errors.

That being said. It’s seems pretty solid!


(Lorenzo Zama) #36

Hi, I tried to install the OFX plugin, I place it in the Macintosh HD/Library/OFX/Plugins Folder, but it wont appear in the OpenFX Library in Resolve.
I run Resolve 14.3 on a Mac Pro 2013 (AMD CARDS) with High Sierra installed.
I tried to install also some of the other Plugins you created, and I had the same result. Only the MATTE one is working. Is my version of Resolve?
Thanks in advance Paul

(Paul Dore) #37

Most of the newer plugins (including ACES OFX) are Cuda only. Most of the legacy plugins are OpenCL compatible. The more advanced features of the new plugins will only work with Cuda, so no plans to attempt further cross compatibility in the near future.

(Lorenzo Zama) #38

Ok, thanks for the quick replay Paul! Great work by the way!

(Paul Dore) #39

The ACES DCTL collection has been updated to the official ACES 1.1 release.

New files:



ACES_LIB/ACES_LMT/LMT_BlueLightArtifactFix.h (formerly LMT_FixHighlightImageArtifacts.h)

Updated files:


The LEGAL_RANGE and SURROUND options are now enabled in the new Output Transform functions.


Resolve breaks ACEScc with rec 709 ODT
(Paul Dore) #40

ACES OFX Plugin has been updated to the official ACES 1.1 release.

ACES 1.1 OFX Plugin macOS

ACES 1.1 OFX Plugin Win10

ACES 1.1 OFX Plugin Linux

ACES 1.1 OFX Source Files

The difference in performance speed between DCTL and OFX Plugin is notable, so consider using the export DCTL function within the plugin (latest ACES_DCTL collection required).

Does ACES support RED WideGamutRGB/Log3G10 and IPP2?
(Alex Forsythe) #41

Has anyone successfully gotten these running on a Macbook Pro?

I have a Mid-2014 MBP with 16GB RAM and a GeForce 750M. I can get them working if I use the Nvidia web driver and cuda, but I keep running into a major problem. When using DCTL or the OFX Plugin Resolve will suddenly suck all my computer resources and basically lock the machine up. There have been a few instances where I was able to quit resolve and the computer came back, but it’s very annoying.

This happens under both Resolve 14 and 15 so I’m thinking it’s related to the Nvidia Driver. Any thoughts would be greatly appreciated.

(Alex Forsythe) #42

FYI … also the OFX plugin doesn’t seem to be working for me in Resolve 14 Studio. Not sure what the issue is there.

(Scott Dyer) #43

I believe this has been asked and answered multiple times in this thread. The plugin requires Resolve 15 since it calls on the DCTL with #include statements.

(Alex Forsythe) #44

@sdyer Below is the quote from @Paul_Dore that the OFX plugin should work in Resolve Lite and Studio in both 14 and 15.

The point that was addressed was @CharlesBoileau trying to export DCTL out of the plugin in Resolve 14. That obviously doesn’t work because DCTL in Resolve 14 doesn’t support #include statements but I believe the plugin itself should still work on Nvidia systems with Resolve 14 based on @Paul_Dore previous comments.

(Paul Dore) #45

I have the same MacBook Pro. In Resolve, go to Preferences/Configuration and select CUDA for GPU processing mode, and Manual for GPU selection mode. You’ll have to save project and restart Resolve for the changes to take effect. If there is still a problem, it may be an issue with your CUDA driver (or something to do with which macOS you’re running).

The ACES DCTL set requires Resolve 15 Studio to work, but the OFX plugin will also work with Resolve 14 (both Studio and free version).

(Alex Forsythe) #46

Thanks @Paul_Dore

GPU Driver Version: 355.
CUDA Driver Version: 396.148
MacOs Version : 10.13.5 (17F77)

Are you running the Nvidia Web Driver or just the stock MacOS GPU driver? Resolve doesn’t seem to recognize my GPU as Cuda capable with the stock MacOS GPU driver.

Thanks again for the confirmation!

(Paul Dore) #47

My MacBook has CUDA driver version: 8.0.90 and
GPU Driver Version: 10.30.25 355. (though it may be a more up to date version, but renamed so that macOS recognises it).

I’m on macOS version 10.13.4

I think I had issues with the GPU Driver when I updated to High Sierra. There’s a possible work around here:

I would first try install the CUDA driver listed above, and then see it that’s enough to get it working properly.


There’s no need to use the web drivers on a real Mac. I use them on a hackintosh, but not on my MacBook.

High Sierra is the culprit in all this.

(Alex Forsythe) #48

Odd … followed the instructions above and it fixed in the “Update Required” issue when using the mac GPU driver, but Resolve still complained about not being able to find a CUDA compatible GPU. It seems to work as long as I use the Nvidia driver.

(Paul Dore) #49

My set-up is specifically suited for compiling plugins for Resolve, hence the CUDA 8.0.90 driver. Otherwise I would probably use the most up to date versions (provided they work). The throttling issue is something worth approaching either Apple or Blackmagic Design about.

(Pedro Saboya Burgos) #50

Hey everyone and Paul!

I’ve been trying to work with ACES inside Resolve’s YRGB mode using DCTLs instead of your ACES OFX plugin, as you recommend.

At first, I tried exporting DCTLs with the proper transforms from the Plugin, but couldn’t due to a permissions issue (even to the default folder). So I’m using your ACES_Sample as a reference, so I could create DCTLs for the transform.

For the IDT/ACES_to_ACEScct, it worked well, just like the OFX.
For the ACEScct_to_ACES/RRT/ODT (rec 709), it didn’t. I can’t figure out what I’m doing wrong.

#include “ACES_LIB/ACES_IDT.h”
#include “ACES_LIB/ACES_LMT.h”
#include “ACES_LIB/ACES_RRT.h”
#include “ACES_LIB/ACES_ODT.h”
DEVICE float3 transform(int p_Width, int p_Height, int p_X, int p_Y, float p_R, float p_G, float p_B)
float3 aces = make_float3(p_R, p_G, p_B);
aces = IDT_Alexa_v3_logC_EI800(aces);
aces = ACES_to_ACEScct(aces);
return aces;

#include “ACES_LIB/ACES_IDT.h”
#include “ACES_LIB/ACES_LMT.h”
#include “ACES_LIB/ACES_RRT.h”
#include “ACES_LIB/ACES_ODT.h”
DEVICE float3 transform(int p_Width, int p_Height, int p_X, int p_Y, float p_R, float p_G, float p_B)
float3 aces = make_float3(p_R, p_G, p_B);
aces = ACEScct_to_ACES(aces)
aces = RRT(aces)
aces = ODT_Rec709_100nits_dim(aces);
return aces;

Can anyone help me figure out what I’m doing wrong?

(Paul Dore) #51

What does it say in the davinci log files? The source of the error can be traced there. Also, list your operating system, version of Resolve, and the exact location of the dctls.

(Nick Shaw) #52

Is that missing ACES_Conversion.h in the includes?