Colour artefacts or breakup using ACES

colorcorrection
resolve
arri
nucoda
Tags: #<Tag:0x00007f3c682acc30> #<Tag:0x00007f3c682acac8> #<Tag:0x00007f3c682ac960> #<Tag:0x00007f3c682ac7d0>

(Joey Foreman) #21

Please try to fix this issue soon. I don’t have the Studio version of Resolve, so cannot use DCTL’s. Currently grading a live concert shot on RED cameras, and everything looks fabulous in ACES except for occasional instances of this color artefacting. These look very bad, and are time-consuming and difficult to ‘repair’ with Resolve’s tools.


(Thomas Mansencal) #22

@Joey_Foreman: Which light sources are creating the issues in your context?

Cheers,

Thomas


(Joey Foreman) #23

In this instance it’s the magenta LED. The artifacts can be seen on the arms, neck, and head. Saturation and hue controls don’t work well (or predictably) on these areas.


(Thomas Mansencal) #24

Thanks a lot!

Cheers,

Thomas


(Nick Shaw) #25

Can you post an R3D snapshot of that image?


(Joey Foreman) #26

Can’t upload directly, but here’s a link:

https://drive.google.com/open?id=0B8jaGdThepZQRDdRVzR2RGtxVTQ


Getting Started with ACES
(Peter) #27

I just tested and the “highlight Fix” makes all the magenta on the shirt disappear. Also a general blue cast is removed from the whole image. I know you don’t have the Studio version, but that are my first findings.

But I got pretty acceptable results with a simple hue vs sat treatment of certain colors. So I am not sure if that’s really a case for the highlight fix like in the first example of Patrick.

Peter


(Thomas Mansencal) #28

I was playing with your image in Nuke using the OpenColorIO 1.0.3 configuration and annoyingly couldn’t reproduce the issue:

DRAGONcolor2 — REDlogFilm to ACEScg — RRT + sRGB ODT

DRAGONcolor2 — REDlogFilm to ACEScg + LMT.Academy.FixHighlights — RRT + sRGB ODT

Cheers,

Thomas


(Peter) #29

That’s exactly what I see with the highlight fix in Resolve.

Peter


(Thomas Mansencal) #30

No major issues either in Davinci Resolve 12.5.2.010 on my end:

Davinci Resolve - Edit

Davinci Resolve - Master Project Settings

Davinci Resolve - Color Management

Cheers,

Thomas


(Nick Shaw) #31

It is possible to bake the matrix into a LUT. I have created one which appears to work, but want to test it a bit more thoroughly before posting it.


(Joey Foreman) #32

Thanks, Nick. A LUT would be great.


(Nick Shaw) #33

Here is the LUT I made:

It uses LogC as the shaper, and therefore covers the input range of LogC 0-1 (-0.017 to 55.08). It is probably possible to get an improved result by using a different shaper, but initial tests indicate it gives a good match to the DCTL. It’s not perfect, but a LUT almost never will be.

Apply, like the DCTL, by right-clicking the timeline thumbnail and choosing the 3D LUT.

Test yourself before using.


(Joey Foreman) #34

Thanks so much, Nick. Finally got around to trying the LUT, but having a strange issue. Pretty sure I placed it in the correct location:

but when I apply it to the timeline thumbnail I get:

…and it has no effect on the clip.

Running version 12.5.4 on Mac OS. Using ACEScct v.1.0.2., REC 709 ODT.

Also tried applying on the color page, and in Project Settings, to no effect.

That said, I was ultimately able to fix the artefacting by pumping in 80% Green tint, meaning that, in the final analysis, it wasn’t actually an ACES problem. So that’s a relief. And possibly the reason I was seeing no effect on the image or waveforms.

Not sure, though, because of the error message.

Peter and Thomas, thank you for testing.


(Nick Shaw) #35

[quote=“Joey_Foreman, post:34, topic:520”]
Thanks so much, Nick. Finally got around to trying the LUT, but having a strange issue. Pretty sure I placed it in the correct location[/quote]
Odd. Sorry about that. I’ve never seen that error message. I just downloaded and checked the downloaded LUT, and it works for me. Although I am running v12.5.2 on the MacBook Pro I am in front of right now.

It looks like the right LUT folder. You can double check by clicking the Open LUT Folder button in the Color Management tab of Project Settings.

Also, just in case the LUT got somehow corrupted in the download, try this zipped version:


(Orash Rahnema) #36

Hi everyone,
this is my very first post in this community, unfortunately i won’t be able to give back as much as i would want, i know close to nothing about colour science and coding.
I am manly a lurker, trying to read and learn as much as i can, I love what aces is about and i actually love to grade in aces, i have done many projects in it.

Anyway, I started testing for my next project and i got the same artefact you were talking about in this thread.
I have tried to use the FixHilights DCTL that Scott Dyer posted before and even if it makes it slightly better it doesn’t fix the problem.

I attach an example of the artefact that i am getting and i will link a dpx of the flat image.

I also want to take the chance to thank everyone that i contributing so much in this community, it’s really helpful!
Orash

Davinci Resolve 12.5
ACEScct
PRORES444XQ
https://drive.google.com/open?id=0B-kmzfWwMPPUQlBseGZITWxOS0E


(Scott Dyer) #37

Interesting example, and thanks for sharing the frame.

What is the encoding of the DPX? In other words, what camera did you select for your Input Transform (IDT)? Was it Alexa?

I assumed Alexa, processed using ACES w/ and w/o the the matrix adjustment and got the following results:

Is this similar to what you saw when applying the DCTL? (If not, then it’s likely something was not applied correctly…)


(Orash Rahnema) #38

Hi Scott!
thanks for the quick reply.
Yes, it’s alexa, I have applied the alexa idt as project base and srgb (as i am delivering for web) as odt.
I’ve then applied the dctl on the first node, the result was slightly better but not as good as your one.

Could it be that by transcoding into dpx 10 bit i have cut out some information on the super saturated pixels?
My test were done with prores444xq straight from camera, i know is not ideal as they are not raw, but aren’t them 16bit?

Edit: today i will try with thee rec709 odt and let you know how it goes, maybe that’s the problem.


(Orash Rahnema) #39

Alright,
I have done few more tests and i didn’t get any success, neither switching odt nor using the dpx rather then the PR444XQ.
I will post the screenshots of my settings, hopefully i will learn something new and really good :smile:


(Scott Dyer) #40

That’s probably why. The DCTL I shared was designed to be applied to linear ACES data (ACES2065-1). To correctly apply it, right click on the clip in the media pool or, if on Color page, right click on the clip. About 3/4 down the menu (just below where it lets you set a per-clip ACES Input Transform) there are options for No LUT, 1D LUT, 3D LUT, or DaVinci CTL: Try applying the DCTL to any problematic shots using this DCTL menu instead of the regular nodes.

The reason yours was not working correctly is because DCTL applied via this per-clip contextual menu is applied directly to the ACES image. Any DCTL applied in the node tree is applied to the current working space - such as ACEScct, in your case - unless additional “conversion” DCTL is used to get the data to the correct state for the application of the matrix.

For example, if you instead chained together a sequence of ACEScct-to-ACES -> LMT.Academy.FixHighlightImageArtifacts -> ACES-to-ACEScct in your node tree then you could get the same visual result as applying DCTL via the contextual menu. Hope this makes sense and that you can similar results to me. Good luck!