BRaw (ACES) export issue

Hello,
I’ve encountered a problem while working with ACES and BRAW footage from the Blackmagic pocket 4K and 6K and I was wondering if anybody has had the same problem and could help me.

I found out that when I work in ACES in DaVinci Resolve, BRAW doesn’t need and IDT, the information comes from the camera metadata, then I did all my grade and I was trying to test if a grade in REC 709 (displayed in REC 709 mode on my monitor) was matching after switching to DCI-P3 (displayed in DCI-P3 mode on my monitor ) and yes. Everything was matching perfectly, but after I exported the 2 clips in the 2 different color spaces, not only they didn’t match with each other (on the respective color mode) but more importantly, they did not match to their respective grade in davinci.
In particular, everything seemed a less saturated, slightly darker, and definitely slightly greener from what I was watching on DaVinci Resolve (please note, I was using the same monitor on the same color space to compare between the export and the reference image from davinci)
It LOOKED LIKE my grade was there but the initial conversion in ACES did not pass through in the export.

(I’m saying “looked like”, because i’m not sure if that is what actually happened, but it’s the best explanation I could give)

Also. Please note that i have had this problem only with BRAW, everything else so far looked fine as far as I could tell.

Has anybody had this problem before and could help me understand what I’m missing?
Thank you so much in advance!

Did you try using the ACES TRANSFORM ofx instead? You could set the Braw footage to BMD FILM (or a variant) and use it that way.

Mmh, I don’t Even know what that is actually. Is it a plug-in or just another way of grading in ACES?

Thank you so much for your answer!