ACES set up for Blender using OCIO

Tags: #<Tag:0x00007f58b69fa0e0>

Thanks to Daniel Brylka for contributing this set up for Blender 2.8 with ACES 1.1 using OpenColorIO.

https://www.toodee.de/?page_id=1720

1 Like

Hi Steve,

thanks for sharing my page. Next time I post it directly here.

Best regards

Daniel

2 Likes

thanks for the contribution!!

Here is the a quick step list:

  • Download the OpenColoIO config for ACES 1.1 from this link:
  • github.com/colour-science/OpenColorIO-Configs/tree/feature/aces-1.1-config
  • Unzip and place the config in your user folder or on a server location.
  • Set a system variable for OCIO to this path to use it for all applications that supports it and don’t have an option in the preferences to set the path manually.
  • Or start Blender with the variable set only for Blender.
  • On the Mac I use Automator to create an App called “Blender_ACES”. In this app I use a shell script to set the variable and start Blender.
  • For Windows I use a simple .bat file.
  • I didn’t find an easier and way.
  • Happy Blending…
  • Oh, the color chart you can find here:
  • github.com/colour-science/colour-nuke/tree/master/colour_nuke/resources/images

I updated the page and added some more images and explanations what happens when you (in this case me) forget to start Blender in ACES but having already a .blend file that contains ACEScg images. This real accident happened with tests in MAYA some years back on a cloud render farm where the OCIO environment was just ignored.

5 Likes

Thanks for the explanation Daniel !

For anyone having issues with Git bevause the repo is big, with big history, and not using LFS, you can use this command:

git clone --depth 1 --single-branch --branch feature/aces-1.1-config https://github.com/colour-science/OpenColorIO-Configs.git
3 Likes

Hi,

The direct link to the .zip file (without history) is here: https://github.com/colour-science/OpenColorIO-Configs/archive/feature/aces-1.1-config.zip

Cheers,

Thomas

4 Likes

Hi,

I followed your instructions and i am starting blender with the .bat approach you showed.

I have some problems with gloss and normal maps.
Normally they are set as non-color data.
These are not available anymore.

Hi Sascha,

it looks to me that you opened a scene file that was not created in an OCIO environment and now it is missing the default colorspace settings?

Do you get the same errors when you start working with a fresh scene?

Greetings

Daniel

Hello there,
I tried to create a .bat file, but didn´t work.
I´m using Blender 2.82a version.

This is my .bat file:

Thx!

Set OCIO-D:…etc
should be
Set OCIO**=**D:…etc

Thanks for this great resource Daniel.
Is there a convenient way to remove or organize hundreds of colorspaces that appear in the dropdown menus?
My resolution is HD, so I can not even fit the whole list in my screen :sweat_smile:

Screenshot-13